package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@d.+e\s[[].+[\]]`)
var str = `hello world, @delete [use0_r]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}