$re = '/@d.+e\s[[].+[\]]/m';
$str = 'hello world, @delete [use0_r]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);