import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\w*\\(*[^)]*[^(]*\\)*\\w*\\)+";
final String string = "CHUOI(<h1>abc)\n"
+ "CHUOI((abc)\n"
+ "CHUOI(abc))\n"
+ "CHUOI((abc)123)\n"
+ "CHUOI(abc)123))\n"
+ "CHUOI(abc))123)\n"
+ "CHUOI((abc)))\n"
+ "CHUOI(abc)123)\n"
+ "CHUOI(abc)ABC(123)\n"
+ "CHUOI(abc(123))\n"
+ "CHUOI(abc)ABC(123))\n"
+ "CHUOI(abc)ABC(132))\n"
+ "CHUOI(abc)))ABC(123(def)))\n\n"
+ "------------------------------ spec-------------------\n"
+ "CHUOI(<h1>%$#<h1>^@321312*&da<hh131>)anc(abc)\n"
+ "CHUOI(<h1>abc)\n"
+ "CHUOI((<h1<h2>~!@)#$%^&*(*(*)_+**(***$#%$$abc)\n"
+ "CHUOI(abc))\n"
+ "CHUOI((abc)123)\n"
+ "CHUOI(abc)123))\n"
+ "CHUOI(abc))123)\n"
+ "CHUOI((abc)))\n"
+ "CHUOI(abc)123)\n"
+ "CHUOI(abc)ABC(123)\n"
+ "CHUOI(abc(123))\n"
+ "CHUOI(abc)ABC(123))\n"
+ "CHUOI(abc)ABC(132))\n"
+ "CHUOI(abc)))ABC(123(def)))\n\n"
+ "CHUOI(<h1(abc)ABC(dadahi)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}