import re
regex = re.compile(r"\(\w*\(*[^)]*[^(]*\)*\w*\)+", flags=re.MULTILINE)
test_str = ("CHUOI(<h1>abc)\n"
"CHUOI((abc)\n"
"CHUOI(abc))\n"
"CHUOI((abc)123)\n"
"CHUOI(abc)123))\n"
"CHUOI(abc))123)\n"
"CHUOI((abc)))\n"
"CHUOI(abc)123)\n"
"CHUOI(abc)ABC(123)\n"
"CHUOI(abc(123))\n"
"CHUOI(abc)ABC(123))\n"
"CHUOI(abc)ABC(132))\n"
"CHUOI(abc)))ABC(123(def)))\n\n"
"------------------------------ spec-------------------\n"
"CHUOI(<h1>%$#<h1>^@321312*&da<hh131>)anc(abc)\n"
"CHUOI(<h1>abc)\n"
"CHUOI((<h1<h2>~!@)#$%^&*(*(*)_+**(***$#%$$abc)\n"
"CHUOI(abc))\n"
"CHUOI((abc)123)\n"
"CHUOI(abc)123))\n"
"CHUOI(abc))123)\n"
"CHUOI((abc)))\n"
"CHUOI(abc)123)\n"
"CHUOI(abc)ABC(123)\n"
"CHUOI(abc(123))\n"
"CHUOI(abc)ABC(123))\n"
"CHUOI(abc)ABC(132))\n"
"CHUOI(abc)))ABC(123(def)))\n\n"
"CHUOI(<h1(abc)ABC(dadahi)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")