package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\@(?P<name>[a-zA-Z\-\_]+))`)
var str = `I recently saw @john-doe riding a bike, did you noticed that too @foo-bar?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}