$re = '/(\@(?P<name>[a-zA-Z\-\_]+))/';
$str = 'I recently saw @john-doe riding a bike, did you noticed that too @foo-bar?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);