package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)Target Account:.*Security ID:\s+(?<Security_ID>[^ ]*)`)
var str = ` LogName=Security
SourceName=Microsoft Windows security auditing.
EventCode=4738
EventType=0
Type=Information
ComputerName=server.domain.com
TaskCategory=User Account Management
OpCode=Info
RecordNumber=00000000
Keywords=Audit Success
Message=A user account was changed.
Subject:
Security ID: DOMAIN\account_1
Account Name: account_1
Account Domain: DOMAIN
Logon ID: 0000000
Target Account:
Security ID: DOMAIN\account_2
Account Name: account_2
Account Domain: DOMAIN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}