// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)Target Account:.*Security ID:\s+(?<Security_ID>[^ ]*)").unwrap();
let string = " LogName=Security
SourceName=Microsoft Windows security auditing.
EventCode=4738
EventType=0
Type=Information
ComputerName=server.domain.com
TaskCategory=User Account Management
OpCode=Info
RecordNumber=00000000
Keywords=Audit Success
Message=A user account was changed.
Subject:
Security ID: DOMAIN\\account_1
Account Name: account_1
Account Domain: DOMAIN
Logon ID: 0000000
Target Account:
Security ID: DOMAIN\\account_2
Account Name: account_2
Account Domain: DOMAIN";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}