$re = '/\",\"thumb\":\"(http.:[^"]*)\"/m';
$str = '","thumb":"https://images-na.ssl-images-amazon.com/images/I/51azLW7w-TL._US40_.jpg","large';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);