re = /\",\"thumb\":\"(http.:[^"]*)\"/m
str = '","thumb":"https://images-na.ssl-images-amazon.com/images/I/51azLW7w-TL._US40_.jpg","large'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end