$re = '/^(?!.*\b\d{12}\b.*).*$/m';
$str = 'string 123456789012 string
string 123456789 string
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);