re = /^(?!.*\b\d{12}\b.*).*$/m
str = 'string 123456789012 string
string 123456789 string
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end