using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""([^\-\^+]+)\""";
string input = @"'""Q%LCJ8^1""+""Q%VOD.L""+""Q%LSEG.L[EQ_LIST]MID_PRICE""+""BRT-""'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}