re = /\"([^\-\^+]+)\"/m
str = '\'"Q%LCJ8^1"+"Q%VOD.L"+"Q%LSEG.L[EQ_LIST]MID_PRICE"+"BRT-"\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end