package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{2}\d{1}\s?\w?`)
var str = `AE1 A D BE1 A D C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}