$re = '/^[a-zA-Z]{2}\d{1}\s?\w?/m';
$str = 'AE1 A D BE1 A D C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);