#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\w._]+)"
Local $sString = "alpha123_4rf" & @CRLF & _
"45beta_Frank" & @CRLF & _
"Red5Great_Sam_Fun" & @CRLF & _
"dan.dan_mmem_ber" & @CRLF & _
"huh_k" & @CRLF & _
"han.jk_jj" & @CRLF & _
"huhu"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)