import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w._]+)";
final String string = "alpha123_4rf\n"
+ "45beta_Frank\n"
+ "Red5Great_Sam_Fun\n"
+ "dan.dan_mmem_ber\n"
+ "huh_k\n"
+ "han.jk_jj\n"
+ "huhu";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}