#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:2\d{3} \d{4} \d{4} \d{4} \d|3\d{3} \d{4} \d{4} \d{4})$"
Local $sString = "2123 1234 1234 1234 5" & @CRLF & _
"3123 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"2234 1234 1234 1234" & @CRLF & _
"3234 1234 1234 1234 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")