$re = '/^(?:2\d{3} \d{4} \d{4} \d{4} \d|3\d{3} \d{4} \d{4} \d{4})$/m';
$str = '2123 1234 1234 1234 5
3123 1234 1234 1234
2234 1234 1234 1234
3234 1234 1234 1234 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);