const regex = /\s+|(?<=\b\p{L}['’])\b/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+|(?<=\\b\\p{L}[\'’])\\b', 'gmu')
const str = `Aujourd'hui séparer l'élément en deux
Je suis d’accord
Je n'en ai pas`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}