$re = '/\s+|(?<=\b\p{L}[\'’])\b/mu';
$str = 'Aujourd\'hui séparer l\'élément en deux
Je suis d’accord
Je n\'en ai pas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);