import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<expiry>\\d{5}|\\d{2}\\w{3})(?P<strike>\\d+(?:\\.\\d+)?)(?P<type>\\w+)";
final String string = " tradingsymbol\n"
+ "0 XYZ2061820500PE\n"
+ "1 XYZ20JUN21000PE\n"
+ "2 ABC20JUN100CE\n"
+ "3 ABC20JUN102.5PE\n"
+ "4 ABC20JUN92.5PE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}