import re
regex = re.compile(r"(?P<expiry>\d{5}|\d{2}\w{3})(?P<strike>\d+(?:\.\d+)?)(?P<type>\w+)", flags=re.MULTILINE)
test_str = (" tradingsymbol\n"
"0 XYZ2061820500PE\n"
"1 XYZ20JUN21000PE\n"
"2 ABC20JUN100CE\n"
"3 ABC20JUN102.5PE\n"
"4 ABC20JUN92.5PE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")