package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[.*?\]\[2\]`)
var str = `[Some Text][1][Some Text][2][Some Text][3][Some Text][4]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}