$re = '/\[.*?\]\[2\]/m';
$str = '[Some Text][1][Some Text][2][Some Text][3][Some Text][4]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);