$re = '/[a-zA-Z]+ \d{2}, \d{1,4}/';
$str = 'april 15, 2014
text text april 15, 2014 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);