re = /[a-zA-Z]+ \d{2}, \d{1,4}/
str = 'april 15, 2014
text text april 15, 2014 text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end