$re = '/^.*?Address:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))/m';
$str = 'Name: John Doe Address: Street 123 ABC
Name: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe City: MyCity Address: Street 123 ABC
Some other textName: John Doe Address: Street 123 ABC City: MyCity
Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address
Name: John DoeAddress: Street 123 ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);