# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?Address:\s*(.*?)(?=\s*(?:Name:|Address:|City:|$))"
test_str = ("Name: John Doe Address: Street 123 ABC \n"
"Name: John Doe Address: Street 123 ABC City: MyCity\n"
"Name: John Doe City: MyCity Address: Street 123 ABC \n"
"Some other textName: John Doe Address: Street 123 ABC City: MyCity\n"
"Name: John Doe Address: Street 123 ABC City: MyCity Address: Second address\n"
"Name: John DoeAddress: Street 123 ABC")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.