$re = '/(.*?)(?:\)|\/)(?:.*?)\n/is';
$str = 'some text (part1)
even some text (part1)
some text / ... (part1) (part2)
(part1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);