// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)(.*?)(?:\)|\/)(?:.*?)\n").unwrap();
let string = "some text (part1)
even some text (part1)
some text / ... (part1) (part2)
(part1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}