package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(.*?)(?:\(|\/)(?:.*?)\n`)
var str = `some text (part1)
even some text (part1)
some text / ... (part1) (part2)
(part1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}