re = /(.*?)(?:\(|\/)(?:.*?)\n/i
str = 'some text (part1)
even some text (part1)
some text / ... (part1) (part2)
(part1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end