import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^line\\scon.*(?:\\n .+)*";
final String string = "!\n"
+ "line con 0\n"
+ " session-timeout 5 \n"
+ " exec-timeout 5 0\n"
+ " password 7 1239211A43054F0202D1D\n"
+ " transport output none\n"
+ "line 2\n"
+ " no activation-character\n"
+ " no exec\n"
+ " transport preferred none\n"
+ " transport output pad telnet rlogin lapb-ta mop udptn v120 ssh\n"
+ " stopbits 1\n"
+ "line vty 0 4\n"
+ " session-timeout 5 \n"
+ " access-class 125 in\n"
+ " exec-timeout 5 0\n"
+ " length 0\n"
+ " transport input ssh\n"
+ " transport output none";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}