# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^line\scon.*(?:\n .+)*"
test_str = ("!\n"
"line con 0\n"
" session-timeout 5 \n"
" exec-timeout 5 0\n"
" password 7 1239211A43054F0202D1D\n"
" transport output none\n"
"line 2\n"
" no activation-character\n"
" no exec\n"
" transport preferred none\n"
" transport output pad telnet rlogin lapb-ta mop udptn v120 ssh\n"
" stopbits 1\n"
"line vty 0 4\n"
" session-timeout 5 \n"
" access-class 125 in\n"
" exec-timeout 5 0\n"
" length 0\n"
" transport input ssh\n"
" transport output none")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.