#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?P<mem_type> \d{4}/\d{4}/\d{4}\s/\d{4})|(certain\s(?P<mem_quality>\w+))"
Local $sString = "<Total Slots :>" & @CRLF & _
" <8 (4-channel per CPU, 8 DIMM per CPU)>" & @CRLF & _
" <Capacity :>" & @CRLF & _
" <Maximum up to 1024GB RDIMM>" & @CRLF & _
" <Memory Type :>" & @CRLF & _
" <fd4 2933/2666/2400 /2133 RDIMM" & @CRLF & _
" bbh567 2933/2666/2400 /2133 LRDIMM>" & @CRLF & _
" <screen :>" & @CRLF & _
" <720>" & @CRLF & _
" <color :>" & @CRLF & _
" <blue>" & @CRLF & _
" <Memory Quality :>" & @CRLF & _
" <Certain 3452345tte READ" & @CRLF & _
" Non certain 7JJEN232 LREAD>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")