package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:(?:Mr|Miss|dr|lord)? )?((?:[A-Z]\w*(?:[ -][A-Z]\w*)*|[a-z]+(?: [a-z]+)))\b`)
var str = `William R. Burroughs III.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}