$re = '/\b(?:(?:Mr|Miss|dr|lord)? )?((?:[A-Z]\w*(?:[ -][A-Z]\w*)*|[a-z]+(?: [a-z]+)))\b/m';
$str = 'William R. Burroughs III.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);