$re = '/(?<=create\sor\sreplace\spackage\sbody\ssomething\.)\S*/m';
$str = 'create or replace package body something.pkg_test is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);