re = /(?<=create\sor\sreplace\spackage\sbody\ssomething\.)\S*/m
str = 'create or replace package body something.pkg_test is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end