re = /^(?!\+37|0037)\+?\d+$/m
str = '+34999888112
0085999345534
003799912345
+37894888112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end