using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}(?:,\d{1,3})*)+(?= USD)";
string input = @"<div class=""priceitem""> 1,231,098 USD <span id=""XUwt-price-mb-aE068a15dcca8E168a15dcca8-tooltipIcon"" class=""tooltip-icon afterPrice info-icon""> <svg class="" xmlns=""http://www.w3.org/2000/svg"" viewBox=""0 0 200 200"" width=""100%"" height=""100%""><use xlink:href=""#common-icon-icon-info""></use></svg> </span> <br></div>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}