const regex = /(\d{1,3}(?:,\d{1,3})*)+(?= USD)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,3}(?:,\\d{1,3})*)+(?= USD)', '')
const str = `<div class="priceitem"> 1,231,098 USD <span id="XUwt-price-mb-aE068a15dcca8E168a15dcca8-tooltipIcon" class="tooltip-icon afterPrice info-icon"> <svg class="" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 200 200" width="100%" height="100%"><use xlink:href="#common-icon-icon-info"></use></svg> </span> <br></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}