$re = '/(\d[\s-]?)?[\(\[\s-]{0,2}?\d{3}[\)\]\s-]{0,2}?\d{3}[\s-]?\d{4}/i';
$str = 'something something here\'s a phone number : (123) 456-7890
(123)-456-7890 is my number, how wonderful is that?
still talking about 123 456 7890, the magnificent phone number
123-456-7890 !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);