re = /(\d[\s-]?)?[\(\[\s-]{0,2}?\d{3}[\)\]\s-]{0,2}?\d{3}[\s-]?\d{4}/i
str = 'something something here\'s a phone number : (123) 456-7890
(123)-456-7890 is my number, how wonderful is that?
still talking about 123 456 7890, the magnificent phone number
123-456-7890 !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end