package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\/\s]+`)
var str = `/pathvalue1/path-value-one
/pathvalue2/path-value
/pathvalue3/pathvaluethree`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}