$re = '/[^\/\s]+/';
$str = '/pathvalue1/path-value-one
/pathvalue2/path-value
/pathvalue3/pathvaluethree';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);