re = /\s*--\/-(.*?)--\/--\s*/m
str = '--/--RedorDead :--/-- Tottenham are the worst team in existence --/--RedorDead :--/-- Tottenham are the worst team in existence'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end