import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+:(?!K1663$).*$";
final String string = "3:K1675\n"
+ "4:K1663\n"
+ "5:K1663\n"
+ "6:K1663\n"
+ "7:K1663\n"
+ "8:K1675\n"
+ "13:K1675\n"
+ "14:K1675";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}